This project has moved. For the latest updates, please go here.

LDAP Connections Issue

Jul 7, 2014 at 8:02 PM
I'm having an issue getting LDAPCP to use the correct LDAP connection.

In the Global Configuration I have manually specified a connection with credentials. I tested the connection (through the Test LDAP Connection button) and it connected successfully. However when I use a peoplepicker control to search for a user no results are displayed. Looking into the ULS logs, I see that the search is not taking place on the specified LDAP connection, but is instead defaulting to: Connect to AD the server is a member of with app pool credentials.

How can I ensure that the LDAP connection I specified is used?


Log file snippet
LDAP connections array is missing in the persisted object LdapcpConfig and default connection was used. Visit LDAPCP admin page and validate it to create the array.
[LDAPCP] LdapcpConfig PersistedObject changed, refreshing configuration
Entering monitored scope ([LDAPCP] Total time spent in all LDAP server(s)). Parent SPClaimProvider.FillSearch()
[LDAPCP] Connect to AD this server is member of, with application pool credentials
Jul 9, 2014 at 1:36 PM
Did you click on "Add LDAP Connection" next to "Test LDAP Connection" button?
Clicking on "OK" on the page doesn't create the LDAP connection, you have to click on the dedicated button for that.
Jul 9, 2014 at 1:47 PM
Yes I did click on "Add LDAP Connection" and it then showed up in the Current LDAP Connections section.
Nov 6, 2014 at 3:58 PM
Edited Nov 6, 2014 at 3:58 PM
Hello Pgo17,
Did you resolve this? I just updated to v 3.3 and I have this same issue. I also clicked the "add" button but the results are still the same
Nov 6, 2014 at 4:31 PM
No, I never did resolve this issue. I instead reverted back to an older version I had.
Nov 6, 2014 at 4:38 PM
Edited Nov 6, 2014 at 4:42 PM
Maybe this is due to an incompatibility between the original schema and the new schema of the LDAPCP persisted object.
Can you reset the configuration and try again?
You can do that from LDAPCP global configuration page > "Reset LDAPCP configuration" button at the bottom.
Please let me know if that works.
P.S: Be aware that this will reset the whole settings and you will have to reapply your claims mappings and custom settings
Nov 6, 2014 at 5:34 PM
I am having the exact same issue. I tried resetting the configuration but had no luck. Please help.
Nov 6, 2014 at 5:35 PM
Edited Nov 6, 2014 at 6:12 PM
Hi Yvand,

I have tried the reset button but it did not help. Odd thing is that when I "test the ldap connection" all seems good. but the logs continue to show that the apppool credentials are being used when using people picker from SharePoint
Nov 6, 2014 at 6:08 PM
I had to revert to the version we had running before the update. v.

Odd thing is that I ran Update-SPSolution on my test environment (exactly the same) for ldapcp and everything installed without a hitch.

Yvand, let us know if you have some new ideas as to why this would happen.

Thank you
Nov 6, 2014 at 6:40 PM
I think I found the issue. When deleting the SPPersistedObject, I noticed the Unprovision and Uncache methods are not getting called. I think the object is not being completely removed.
Nov 7, 2014 at 12:55 PM
You can delete the persisted object with the cmd below:
stsadm -o deleteconfigurationobject -id 5D306A02-A262-48AC-8C44-BDB927620227
Normally this cmd is not supported, but in this case we don't really care since it deletes LDAPCP configuration (not an OOB SharePoint object).
Please let me know if that changes something.
May 5, 2015 at 10:17 PM
This seems like a similar issue that I am experience. Sorry I had posted a new thread for it, but didn't find this until I dug this out of the ULS logs:

LDAP connections array is missing in the persisted object LdapcpConfig and default connection was used. Visit LDAPCP admin page and validate it to create the array.

Seems when I add a new LDAP entry in the admin page it doesn't stick around. At some point it will disappear and then seems to come back sometimes when you refresh the page. I tried doing the stsadm command above as well as completely removing the solution and redeploying it with no success. Any help would be appreciated.