This project has moved. For the latest updates, please go here.

Problems connecting to LDAP

Oct 9, 2015 at 2:10 AM
Hi Yvand,

We've used your LDAPCP v3.7.0.0 and everything worked great. A few weeks ago, however we seem to have lost connectivity through SharePoint. We've used tools to try to connect to Ldap using the same credentials/path and we were able to connect and query it. However when we try to use the "Test LDAP Connection" in the central admin page we receive this error

Unable to connect to LDAP for following reason:
The server is not operational.
It may be expected if w3wp process of central admin has intentionally no access to LDAP server.

but we are able to connect using other tools. Any pointers on why this is happening in SharePoint?
Oct 9, 2015 at 12:02 PM
did you try to run your tools with the same account that runs w3wp processes?
If it doesn't help I suggest you create a console application that connects to LDAP server using DirectoryEntry class ( ), since this is what LDAPCP is using.
Oct 12, 2015 at 4:16 AM

I tried running the tool with the same account as the w3wp process. I even created a console application that connects to the LDAP server, and i'm receiving the same error.
Any other ideas?

Oct 12, 2015 at 12:22 PM
Well, you reproduce the issue with your tool so it's clearly not a problem related to SharePoint or LDAPCP.
There can be a thousand possible reasons for a LDAP connection error, you should make some research on Internet.